Множественные уязвимости в UMI.CMS

Дата публикации:
08.09.2009
Дата изменения:
08.09.2009
Всего просмотров:
6120
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
UMI.CMS 2.x
Уязвимые версии: UMI.CMS 2.7.3 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за использования алгоритма хеширования md5 для хранения сгенерированных результатов каптчи в файле куки. Удаленный пользователь может обойти защиту от автоматической отправки сообщений и произвести рассылку спама. 2. Уязвимость существует из-за недостаточной обработки входных данных в поле "Название" в модуле "Настройка-Мои блоги" и в поле "Заголовок сообщения" в модуле "Новое сообщение". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.umi-cms.ru

Решение: Установите исправление с сайта производителя.

Ссылки: http://onsec.ru/vuln?id=7
http://onsec.ru/vuln?id=6

или введите имя

CAPTCHA