Множественные уязвимости в Ticket Support Script

Дата публикации:
08.09.2009
Дата изменения:
08.09.2009
Всего просмотров:
1104
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ticket Support Script 1.x
Уязвимые версии: Ticket Support Script 1.1, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности, выполнить произвольные SQL команды и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной проверки расширений загружаемых файлов в сценарии ticket.php. Удаленный пользователь может загрузить произвольный PHP файл и выполнить его на системе с привилегиями Web сервера.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "user" и "pass" в сценарии admin.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточного ограничения доступа для пользователей на загрузку файлов, даже при отключенном функционале загрузки файлов. Удаленный пользователь может с помощью специально сформированного запроса загрузить потенциально опасные файлы на систему.

URL производителя: www.ticketsupportscript.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/9591

или введите имя

CAPTCHA