Межсайтовый скриптинг в DotNetNuke

Дата публикации:
07.09.2009
Дата изменения:
07.09.2009
Всего просмотров:
927
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DotNetNuke 4.x
DotNetNuke 5.x
Уязвимые версии: DotNetNuke версии до 4.9.5 и 5.1.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в именах путей в языковых объектах интерфейса. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре специально сформированных данных. Для успешной эксплуатации уязвимости требуется наличие многоязыковой поддержки.

2. Уязвимость существует из-за ошибки при обработке некоторых данных в ClientAPI. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.dotnetnuke.com

Решение: Установите последнюю версию 4.9.5 или 5.1.2 с сайта производителя.

Ссылки: http://www.dotnetnuke.com/News/SecurityPolicy/securitybulletinno28/tabid/1363/Default.aspx
http://www.dotnetnuke.com/News/SecurityPolicy/securitybulletinno29/tabid/1364/Default.aspx

или введите имя

CAPTCHA