Межсайтовый скриптинг в Ruby on Rails

Дата публикации:
07.09.2009
Дата изменения:
07.09.2009
Всего просмотров:
1159
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby on Rails 2.x
Уязвимые версии: Ruby on Rails версии до 2.2.3 и 2.3.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в кодировке Unicode. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Также сообщается о слабом алгоритме расчета времени в для файлов куки.

URL производителя: www.rubyonrails.org

Решение: Установите последнюю версию 2.2.3 или 2.3.4 с сайта производителя.

Ссылки: http://weblog.rubyonrails.org/2009/9/4/xss-vulnerability-in-ruby-on-rails
http://weblog.rubyonrails.org/2009/9/4/timing-weakness-in-ruby-on-rails

или введите имя

CAPTCHA