Отказ в обслуживании в Firebird

Дата публикации:
29.07.2009
Дата изменения:
03.09.2009
Всего просмотров:
824
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Firebird 1.x
Firebird 2.x
Уязвимые версии: Firebird версии 1.x, 2.x

Описание:
Уязвимость позволяет удаленному пользователю произвести DoS атаку.

Уязвимость существует из-за ошибки при обработке "op_connect_request" пакетов. Удаленный пользователь может с помощью специально сформированного пакета аварийно завершить работу приложения.

URL производителя: www.firebirdsql.org

Решение: Установите исправление из CVS репозитория производителя.

Журнал изменений:

03.09.2009
Незначительные изменения.

Ссылки: CORE-2009-0707: Firebird SQL op_connect_request main listener shutdown vulnerability
http://tracker.firebirdsql.org/browse/CORE-2563

или введите имя

CAPTCHA