Уязвимость при обработке сертификатов в wget

Дата публикации:
03.09.2009
Дата изменения:
05.11.2009
Всего просмотров:
1113
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNU wget 1.x
Уязвимые версии: wget 1.x

Описание:
Уязвимость позволяет удаленному пользователю произвести спуфинг атаку.

Уязвимость существует из-за ошибки при обработке SSL сертификатов, содержащих символ '\0' в некоторых полях. Удаленный пользователь может подменить сертификаты. Уязвимость относится к:
www.securitylab.ru/vulnerability/383341.php

URL производителя: www.gnu.org/software/wget/wget.html

Решение: Установите последнюю версию 1.12 с сайта производителя.

Журнал изменений:

05.11.2009
Изменена секция «Решение».

Ссылки: http://addictivecode.org/pipermail/wget-notify/2009-August/001808.html
http://hg.addictivecode.org/wget/mainline/rev/1eab157d3be7
http://permalink.gmane.org/gmane.comp.web.wget.general/8972

или введите имя

CAPTCHA