Выполнение произвольного кода в Shockwave Player

Дата публикации:
24.06.2009
Дата изменения:
28.08.2009
Всего просмотров:
811
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1860
CVE-2009-2186
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Shockwave Player 11.x
Уязвимые версии: Shockwave Player версии до 11.5.0.600

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки при обработке Shockwave Player 10 данных. Удаленный пользователь может с помощью специально сформированного Adobe Director файла вызвать повреждение памяти и выполнить произвольный код на целевой системе.

URL производителя: www.adobe.com/products/shockwaveplayer/

Решение: Установите последнюю версию 11.5.0.600 с сайта производителя.

Ссылки: APSB09-08: Security Update available for Shockwave Player
ZDI-09-044: Adobe Shockwave Player Director File Parsing Pointer Overwrite Vulnerability

или введите имя

CAPTCHA