Выполнение произвольного PHP кода в WordPress WP-Syntax Plugin

Дата публикации:
26.08.2009
Дата изменения:
26.08.2009
Всего просмотров:
4045
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress WP-Syntax Plugin 0.x
Уязвимые версии: WordPress WP-Syntax Plugin 0.9.8, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "test_filter[]" в сценарии wp-syntax/test/index.php, перед вызовом функции call_user_func_array(). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP код на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: wordpress.org/extend/plugins/wp-syntax/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/9431

или введите имя

CAPTCHA