Межсайтовый скриптинг в XOOPS

Дата публикации:
20.08.2009
Дата изменения:
20.08.2009
Всего просмотров:
1078
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Xoops 2.x
Уязвимые версии: XOOPS 2.3.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "op" в сценарии modules/pm/viewpmsg.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.xoops.org

Решение: Установите исправление из SVN репозитория производителя.
xoops.svn.sourceforge.net/viewvc/xoops/XoopsCore/trunk/htdocs/modules/pm/viewpmsg.php?r1=2621&r2=3292

Ссылки: http://www.senseofsecurity.com.au/research/it-security-advisories.php

или введите имя

CAPTCHA