Множественные уязвимости в fuzzylime (cms)

Дата публикации:
14.07.2009
Дата изменения:
14.07.2009
Всего просмотров:
996
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-2176
CVE-2009-2177
CVE-2008-6834
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
fuzzylime (cms) 3.x
Уязвимые версии: fuzzylime (cms) 3.03a, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю перезаписать произвольные файлы, получить доступ к важным данным и вызвать отказ в обслуживании.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "list" в сценарии code/confirm.php и в параметре "template" в сценарии code/display.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "s" в сценарии code/display.php. Удаленный пользователь может перезаписать произвольные файлы на системе с привилегиями Web сервера. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: cms.fuzzylime.co.uk

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/8978

или введите имя

CAPTCHA