Множественные уязвимости в Apple Safari

Дата публикации:
09.07.2009
Дата изменения:
09.07.2009
Всего просмотров:
2410
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1724
CVE-2009-1725
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apple Safari 4.x
Уязвимые версии: Apple Safari версии до 4.0.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки при обработке родительских и верхних объектов в компоненте WebKit. Удаленный пользователь может с помощью специально сформированного сайта выполнить произвольный код сценария в браузере жертвы в контексте безопасности другого сайта.

2. Уязвимость существует из-за ошибки в компоненте WebKit при обработке числовых ссылок. Удаленный пользователь может с помощью специально сформированного Web сайта вызвать повреждение памяти и выполнить произвольный код на целевой системе.

URL производителя: www.apple.com/safari/

Решение: Установите последнюю версию 4.0.2 с сайта производителя.

Ссылки: About the security content of Safari 4.0.2

или введите имя

CAPTCHA