Множественные уязвимости в FireStats

Дата публикации:
02.07.2009
Дата изменения:
02.07.2009
Всего просмотров:
1662
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-2143
CVE-2009-2144
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FireStats 1.x (плагин к WordPress)
Уязвимые версии: FireStats версии до 1.6.2-stable

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "fs_javascript" в сценарии wp-content/plugins/firestats/firestats-wordpress.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: firestats.cc

Решение: Установите последнюю версию 1.6.2-stable с сайта производителя.

Ссылки: http://firestats.cc/wiki/ChangeLog#a1.6.2-stable13062009
http://milw0rm.com/exploits/8945

или введите имя

CAPTCHA