Выполнение произвольного кода в Foxit Reader JPEG2000/JBIG Decoder Add-On

Дата публикации:
23.06.2009
Дата изменения:
02.07.2009
Всего просмотров:
3551
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-0690
CVE-2009-0691
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Foxit Reader JPEG2000/JBIG Decoder Add-On 2.x
Уязвимые версии: Foxit Reader JPEG2000/JBIG Decoder Add-On 2.0 Build 2009.303, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки при обработке боксов в JPEG 2000 потоке. Удаленный пользователь может с помощью PDF файла, содержащего специально сформированное JPEG 2000 изображение, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.foxitsoftware.com/pdf/reader/addons.htm

Решение: Установите последнюю версию 2.0 Build 2009.616 с сайта производителя.

Журнал изменений:

02.07.2009
Изменены название и описание уязвимости, понижен рейтинг опасности.

Ссылки: http://www.kb.cert.org/vuls/id/251793
http://www.foxitsoftware.com/pdf/reader/security.htm#0602

или введите имя

CAPTCHA