Переполнение буфера в библиотеке ToolTalk в IBM AIX

Дата публикации:
19.06.2009
Дата изменения:
30.06.2009
Всего просмотров:
1050
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
AIX 5.x
AIX 6.x
Уязвимые версии: IBM AIX версии 5.2.0, 5.3.0, 5.3.7, 5.3.8, 5.3.9, 5.3.10, 6.1.0, 6.1.1, 6.1.2 и 6.1.3

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции _tt_internal_realpath() в библиотеке ToolTalk (libtt.a). Удаленный пользователь может с помощью специально сформированного запроса к серверу баз данных ToolTalk , содержащего слишком длинную XDR кодированную строку в кодировке ASCII, вызвать переполнение стека и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости rpc.ttdbserver должен быть включен в etc/inetd.conf.

URL производителя: www.ibm.com

Решение: Установите исправление с сайта производителя.

Журнал изменений:

30.06.2009
Изменено название и описание уязвимости.

Ссылки: AIX libtt.a rpc.ttdbserver remote buffer overflow vulnerability
http://risesecurity.org/advisories/RISE-2009001.txt

или введите имя

CAPTCHA