Переполнение буфера в Perl Compress::Raw::Zlib

Дата публикации:
14.06.2009
Дата изменения:
14.06.2009
Всего просмотров:
1539
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Compress::Raw::Zlib 2.x (модуль к Perl)
Уязвимые версии: Compress::Raw::Zlib (модуль к Perl) версии до 2.017

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки завышения на единицу в функции "inflate()" в файле Zlib.xs. Удаленный пользователь может с помощью специально сформированных сжатых данных вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: search.cpan.org/dist/Compress-Raw-Zlib/

Решение: Установите последнюю версию 2.017 с сайта производителя.

Ссылки: https://bugzilla.redhat.com/show_bug.cgi?id=504386

или введите имя

CAPTCHA