Множественные уязвимости в Drupal NodeQueue Module

Дата публикации:
14.06.2009
Дата изменения:
14.06.2009
Всего просмотров:
1198
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal NodeQueue Module 5.x
Drupal NodeQueue Module 6.x
Уязвимые версии: Drupal NodeQueue Module версии до 5.x-2.7 и 6.x-2.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и обойти некоторые ограничения безопасности..

1. Уязвимость существует из-за недостаточной обработки входных данных в именах. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуются привилегии "administer taxonomy".

2. Уязвимость существует из-за недостаточного ограничения доступа к отображаемым названиям узлов.

URL производителя: drupal.org/project/nodequeue

Решение: Установите последнюю версию 5.x-2.7 или 6.x-2.2 с сайта производителя.

Ссылки: http://drupal.org/node/488092
http://lampsecurity.org/drupal-nodeque-xss-vulnerability

или введите имя

CAPTCHA