Отказ в обслуживании в Apache APR-util

Дата публикации:
08.06.2009
Дата изменения:
19.08.2009
Всего просмотров:
1442
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-0023
CVE-2009-1955
CVE-2009-1956
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache APR-util 1.x
Apache APR-util 0.x
Уязвимые версии:
Apache APR-util версии до 0.9.17
Apache APR-util версии до 1.3.7

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести DoS атаку.

1. Уязвимость существует из-за ошибки при обработке XML файлов. Удаленный пользователь может с помощью специально сформированного XML файла потребить все доступную память на системе.

2. Уязвимость существует из-за ошибки в функции "apr_strmatch_precompile()" в файле strmatch/apr_strmatch.c. Удаленный пользователь может вызвать отказ в обслуживании приложения.

3. Уязвимость существует из-за ошибки завышения на единицу в функции "apr_brigade_vprintf()" в файле buckets/apr_brigade.c. Удаленный пользователь может получить доступ к важным данным или вызвать отказ в обслуживании приложения. Для удачной эксплуатации уязвимости возможно требуется тупоконечная система.

URL производителя: apr.apache.org

Решение: Установите последнюю версию 0.9.17 или 1.3.7 с сайта производителя.

Журнал изменений:

19.08.2009
Изменена секция «Программа», добавлено Apache APR-util 0.x

Ссылки: Apache mod_dav / svn Remote Denial of Service Exploit
http://www.apache.org/dist/apr/CHANGES-APR-UTIL-1.3
http://mail-archives.apache.org/mod_mbox/apr-dev/200904.mbox/%3C49F21CD2.5020105@collab.net%3E
http://www.apache.org/dist/apr/CHANGES-APR-UTIL-0.9

или введите имя

CAPTCHA