Множественные уязвимости в Podcast Generator

Дата публикации:
08.06.2009
Дата изменения:
08.06.2009
Всего просмотров:
1216
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Podcast Generator 1.x
Уязвимые версии: Podcast Generator 1.2, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю удалить произвольные файлы и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "file" и "ext" в сценарии core/admin/delete.php. Удаленный пользователь может с помощью специально сформированного запроса удалить произвольные файлы на системе. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[absoluteurl]" в сценариях core/archive_cat.php, core/admin/itunescategories.php и core/admin/login.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[theme_path]" в сценарии core/themes.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: podcastgen.sourceforge.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Podcast Generator <= 1.2 unauthorized Re-Installation Remote Exploit
http://milw0rm.com/exploits/8860

или введите имя

CAPTCHA