PHP-инклюдинг в DokuWiki

Дата публикации:
01.06.2009
Дата изменения:
01.06.2009
Всего просмотров:
1914
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DokuWiki
Уязвимые версии: DokuWiki версии до 2009-02-14b от 26.05.2009

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "config_cascade" в сценарии inc/init.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: wiki.splitbrain.org/wiki:dokuwiki

Решение: Установите последнюю версию 2009-02-14b от 26.05.2009 с сайта производителя.

Ссылки: http://milw0rm.com/exploits/8781

или введите имя

CAPTCHA