Множественные уязвимости в Drupal Email Verification Module

Дата публикации:
28.05.2009
Дата изменения:
28.05.2009
Всего просмотров:
2460
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Email Verification Module 5.x
Drupal Email Verification Module 6.x
Уязвимые версии: Drupal Email Verification Module версии до 5.x-2.1 и 6.x-1.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в имени пользователя и email адресе. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре списка неподтвержденных email адресов.

2. Уязвимость существует из-за того, что доступ к списку неподтвержденных email адресов ограничен привилегиями "access content". Злоумышленник может получить доступ к списку неподтвержденных email адресов, не имея привилегий администратора приложения. Уязвимость распространяется только на Drupal 5.x.

URL производителя: drupal.org/project/email_verify

Решение: Установите последнюю версию 5.x-2.1 или 6.x-1.2 с сайта производителя.

Ссылки: http://drupal.org/node/468452

или введите имя

CAPTCHA