Ошибка завышения на единицу в NSD

Дата публикации:
28.05.2009
Дата изменения:
28.05.2009
Всего просмотров:
1961
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NSD 3.x
Уязвимые версии: NSD версии до 3.2.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "packet_read_query_section()" в файле packet.c. Удаленный пользователь может вызвать однобайтное переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.nlnetlabs.nl/nsd/

Решение: Установите последнюю версию 3.2.2 с сайта производителя.

Ссылки: http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html

или введите имя

CAPTCHA