Множественные уязвимости в Coppermine Photo Gallery

Дата публикации:
28.05.2009
Дата изменения:
28.05.2009
Всего просмотров:
3085
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Coppermine Photo Gallery 1.x
Уязвимые версии: Coppermine Photo Gallery 1.4.22, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения, получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[cat]" в сценарии thumbnails.php, когда параметр "album" установлен в значение "alpha". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена и опция "register_globals" включена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[USER][lang]". Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для выполнения произвольных команд злоумышленник должен иметь привилегии на загрузку файлов, а также, опция "magic_quotes_gpc" должна быть отключена и опция "register_globals" включена в конфигурационном файле PHP.

URL производителя: coppermine-gallery.net

Решение: Установите последнюю версию 1.4.23 с сайта производителя.

Ссылки: Coppermine Photo Gallery <= 1.4.22 Remote Exploit
http://sourceforge.net/project/shownotes.php?release_id=684274

или введите имя

CAPTCHA