Переполнение буфера в Cyrus SASL

Дата публикации:
26.05.2009
Дата изменения:
26.05.2009
Всего просмотров:
1591
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Cyrus SASL Library 2.x
Уязвимые версии: Cyrus SASL версии до 2.1.23

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за небезопасного использования функции "sasl_encode64()" в файле lib/saslutil.c. Удаленный пользователь может при некоторых обстоятельствах вызвать переполнение буфера и скомпрометировать целевую систему.

URL производителя: asg.web.cmu.edu/sasl/sasl-library.html

Решение: Установите последнюю версию 2.1.23 с сайта производителя.

Ссылки: http://www.kb.cert.org/vuls/id/238019

или введите имя

CAPTCHA