Переполнение буфера в Sendmail

Дата публикации:
25.05.2009
Дата изменения:
25.05.2009
Всего просмотров:
2434
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Sendmail 8.x
Уязвимые версии: Sendmail версии до 8.13.2

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке X-* заголовков. Удаленный пользователь может с помощью специально сформированного email сообщения, содержащего слишком длинный X-* заголовок (например, X-Testing), вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

Примечание: уязвимость была устранена в 2004 году, но о ней стало известно только сейчас.

URL производителя: www.sendmail.org

Решение: Установите последнюю версию 8.13.2 или выше с сайта производителя.

Ссылки: Sendmail < 8.13.2 Heap-based Buffer Overflow PoC
http://www.nmrc.org/~thegnome/blog/apr09/
http://www.sendmail.org/releases/8.13.2

или введите имя

CAPTCHA