Множественные уязвимости в openWYSIWYG

Дата публикации:
22.05.2009
Дата изменения:
22.05.2009
Всего просмотров:
2782
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
openWYSIWYG 1.x
Уязвимые версии: openWYSIWYG 1.4.7, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточного ограничения доступа к сценарию addons/imagelibrary/insert_image.php. Удаленный пользователь может загрузить произвольные изображения на систему.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "dir" в сценарии addons/imagelibrary/select_image.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть структуру директорий и списки изображений.

URL производителя: www.openwebware.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: eggBlog <= 4.1.1 Local Directory Transversal Exploit
http://milw0rm.com/exploits/8654

или введите имя

CAPTCHA