Межсайтовый скриптинг в Project Woodstock

Дата публикации:
20.05.2009
Дата изменения:
20.05.2009
Всего просмотров:
1670
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Project Woodstock 4.x
Уязвимые версии: Project Woodstock 4.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в кодировке UTF-7 при обработке 404 ошибки сервера. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости браузер пользователя должен быть настроен на автоматическое определение кодировок.

URL производителя: woodstock.dev.java.net/index.html

Решение: Установите исправление из CVS репозитория производителя.

Ссылки: http://www.nabble.com/Re:--DSECRG--Sun-Glassfish-Multiple-Security-Vulnerabilities-p23002524.html
http://dsecrg.com/pages/vul/show.php?id=138

или введите имя

CAPTCHA