Переполнение буфера в NTP

Дата публикации:
19.05.2009
Дата изменения:
19.05.2009
Всего просмотров:
4378
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NTP 4.x
Уязвимые версии: NTP версии до 4.2.4p7

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "crypto_recv()" в файле ntpd/ntp_crypto.c. Удаленный пользователь может с помощью специально сформированного пакета, отправленного ntpd демону, вызвать переполнение стека и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости требуется, чтобы Autokey Authentication была настроена через "crypto pw [password]" в файле ntp.conf.

URL производителя: www.ntp.org

Решение: Установите последнюю версию 4.2.4p7 с сайта производителя.

Ссылки: https://lists.ntp.org/pipermail/announce/2009-May/000062.html
http://www.kb.cert.org/vuls/id/853097

или введите имя

CAPTCHA