Множественные уязвимости в Leap

Дата публикации:
19.05.2009
Дата изменения:
19.05.2009
Всего просмотров:
2781
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1613
CVE-2009-1614
CVE-2009-1615
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Leap 0.x
Уязвимые версии: Leap 0.1.4, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "msg". Удаленный пользователь может с помощью специально сформированного комментария выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре специально сформированного комментария. Для успешной эксплуатации уязвимости функционал комментариев должен быть включен.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "searchterm". Удаленный пользователь может с помощью специально сформированного поискового запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре специально сформированного комментария.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "email" на странице входа. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

4. Уязвимость существует из-за недостаточной обработки входных данных в параметре "searchterm". Удаленный пользователь может с помощью специально сформированного поискового запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: leap.gowondesigns.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Leap CMS 0.1.4 (searchterm) Blind SQL Injection Exploit
http://milw0rm.com/exploits/8577

или введите имя

CAPTCHA