Множественные уязвимости в Drupal

Дата публикации:
19.05.2009
Дата изменения:
19.05.2009
Всего просмотров:
1959
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1575
CVE-2009-1576
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 5.x
Drupal 6.x
Уязвимые версии: Drupal версии до 5.17 и 6.11

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может с помощью специально сформированный страницы произвести CSRF нападение и получить доступ к данным HTML форм.

URL производителя: drupal.org

Решение: Установите последнюю версию до 5.17 или 6.11 с сайта производителя.

Ссылки: http://drupal.org/node/449078

или введите имя

CAPTCHA