Межсайтовый скриптинг в Coppermine Photo Gallery

Дата публикации:
19.05.2009
Дата изменения:
19.05.2009
Всего просмотров:
2844
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Coppermine Photo Gallery 1.x
Уязвимые версии: Coppermine Photo Gallery версии до 1.4.22

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "css" в сценарии docs/showdoc.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: coppermine-gallery.net

Решение: Установите последнюю версию 1.4.22 с сайта производителя.

Ссылки: http://forum.coppermine-gallery.net/index.php/topic,59247.0.html
http://forum.coppermine-gallery.net/index.php/topic,59237.0.html
http://gsasec.blogspot.com/2009/04/coppermine-photo-gallery-1421-cross.html

или введите имя

CAPTCHA