Переполнение буфера в libmodplug

Дата публикации:
13.05.2009
Дата изменения:
13.05.2009
Всего просмотров:
1402
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libmodplug 0.x
Уязвимые версии: libmodplug версии до 0.8.7

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "PATinst()" в файле src/load_pat.c. Удаленный пользователь может с помощью специально сформированного файла вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: sourceforge.net/projects/modplug-xmms/

Решение: Установите последнюю версию 0.8.7 с сайта производителя.

Ссылки: http://sourceforge.net/tracker/?func=detail&aid=2777467&group_id=1275&atid=301275

или введите имя

CAPTCHA