Переполнение буфера в 010 Editor

Дата публикации:
08.05.2009
Дата изменения:
08.05.2009
Всего просмотров:
1606
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
010 Editor 3.x
Уязвимые версии: 010 Editor версии до 3.0.5

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке бинарных шаблонов. Удаленный пользователь может с помощью специально сформированного шаблона, содержащего слишком длинные строки, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.sweetscape.com/010editor/

Решение: Установите последнюю версию 3.0.5 с сайта производителя.

Ссылки: http://www.sweetscape.com/010editor/release_notes.html
http://security.bkis.vn/?p=580

или введите имя

CAPTCHA