Обход ограничений безопасности в apt

Дата публикации:
07.05.2009
Дата изменения:
07.05.2009
Всего просмотров:
1534
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1300
CVE-2009-1358
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
apt 0.x
Уязвимые версии: apt версии до 0.7.21

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за того, что приложение проверяет возвращаемое значение "GOODSIG" вместо "VALIDSIG" при запуске "gpgv" для проверки подлинности пакетов. Злоумышленник может подписать приложения просроченным или отозванным ключем.

URL производителя: packages.debian.org/search?searchon=sourcenames&keywords=apt

Решение: Установите последнюю версию 0.7.21 с сайта производителя.

Ссылки: http://packages.debian.org/changelogs/pool/main/a/apt/apt_0.7.21/changelog#versionversion0.7.21
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=433091

или введите имя

CAPTCHA