Целочисленное переполнение в libmodplug

Дата публикации:
07.05.2009
Дата изменения:
07.05.2009
Всего просмотров:
1499
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libmodplug 0.x
Уязвимые версии: libmodplug версии до 0.8.6

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за целочисленного переполнения при обработке MED файлов в функции "CSoundFile::ReadMed()" в файле src/load_med.cpp. Удаленный пользователь может с помощью специально сформированного MED файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: sourceforge.net/projects/modplug-xmms/

Решение: Установите последнюю версию 0.8.6 с сайта производителя.

Ссылки: http://sourceforge.net/project/shownotes.php?release_id=677065&group_id=1275

или введите имя

CAPTCHA