Множественные уязвимости в udev

Дата публикации:
06.05.2009
Дата изменения:
15.05.2009
Всего просмотров:
1833
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1185
CVE-2009-1186
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
udev 1.x
Уязвимые версии: udev версии до 1.4.1

Описание:
Обнаруженные уязвимости позволяют локальному пользователю вызвать отказ в обслуживании и повысить свои привилегии на системе.

1. Уязвимость существует из-за ошибки проверки границ данных в функции "util_path_encode()" в файле udev/lib/libudev-util.c. Локальный пользователь может с помощью специально сформированных данных аварийно завершить работу приложения.

2. Уязвимость существует из-за недостаточной проверки подлинности учетных данных, полученных в NETLINK сообщениях. Злоумышленник может отправить multicast NETLINK сообщения и повысить свои привилегии на системе.

URL производителя: www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html

Решение: Установите последнюю версию 1.4.1 с сайта производителя.

Журнал изменений:

15.05.2009
Добавлен PoC код.

Ссылки: UDEV 1.4.1 Local Privilege Escalation Exploit
Linux Kernel 2.6 UDEV < 141 Local Privilege Escalation Exploit
https://lists.ubuntu.com/archives/ubuntu-security-announce/2009-April/000884.html
https://bugzilla.redhat.com/show_bug.cgi?id=495051
https://bugzilla.redhat.com/show_bug.cgi?id=495052

или введите имя

CAPTCHA