SQL-инъекция в Geeklog

Дата публикации:
04.05.2009
Дата изменения:
04.05.2009
Всего просмотров:
1838
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Geeklog 1.x
Уязвимые версии: Geeklog 1.5.2sr2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения и скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "username" в функции SEC_authenticate() в сценарии system/lib-security.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Злоумышленник может установить привилегии staticpages.PHP и выполнить произвольный PHP код на целевой системе с привилегиями Web сервера.

URL производителя: www.geeklog.net

Решение: Установите последнюю версию 1.5.2sr3 с сайта производителя.

Ссылки: Geeklog <=1.5.2 SEC_authenticate()/PHP_AUTH_USER SQL Injection Exploit
http://www.geeklog.net/article.php/webservices-exploit

или введите имя

CAPTCHA