Множественные уязвимости в glFusion

Дата публикации:
29.04.2009
Дата изменения:
29.04.2009
Всего просмотров:
1965
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1281
CVE-2009-1282
CVE-2009-1283
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
glFusion 1.x
Уязвимые версии: glFusion версии до 1.1.3

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "glf_session" файла куки в сценарии private/system/lib-session.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.glfusion.org

Решение: Установите последнюю версию 1.1.3 с сайта производителя.

Ссылки: glFusion <= 1.1.2 COM_applyFilter()/cookies Blind SQL Injection Exploit
http://www.glfusion.org/article.php/glfusion113

или введите имя

CAPTCHA