Межсайтовый скриптинг в Joomla!

Дата публикации:
29.04.2009
Всего просмотров:
3346
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1279
CVE-2009-1280
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Joomla! 1.x
Уязвимые версии: Joomla! 1.5.9, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в компонентах "com_content", "com_admin" и "com_search". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов в компоненте "com_media". Удаленный пользователь может произвести CSRF нападение.

URL производителя: www.joomla.org

Решение: Установите последнюю версию 1.5.10 с сайта производителя.

Ссылки: http://developer.joomla.org/security/news/294-20090302-core-comcontent-xss.html
http://developer.joomla.org/security/news/293-20090301-core-multiple-xsscsrf.html

или введите имя

CAPTCHA