Переполнение буфера в Ghostscript

Дата публикации:
05.04.2009
Дата изменения:
28.04.2009
Всего просмотров:
819
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ghostscript 8.x
Уязвимые версии: Ghostscript версии до 8.64

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "pdf_base_font_alloc()" в файле src/gdevpdtb.c. Удаленный пользователь может во время конвертации специально сформированного Postscript файла в PDF файл вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.ghostscript.com

Решение: Установите последнюю версию 8.64 с сайта производителя.

Ссылки: http://bugs.ghostscript.com/show_bug.cgi?id=690211

или введите имя

CAPTCHA