Множественные уязвимости в OpenX

Дата публикации:
28.04.2009
Дата изменения:
28.04.2009
Всего просмотров:
2554
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenX (ранее Openads и phpAdsNew) 2.x
Уязвимые версии: OpenX версии до 2.4.11, 2.6.5 и 2.8.0

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "email" в сценарии www/admin/sso-accounts.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "trackerid" в сценарии www/delivery/tjs.php, и возможно в других параметрах. Удаленный пользователь может удалить произвольные файлы на системе.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "OAID" файла куки в сценарии www/delivery/tjs.php and adview.php и в параметре "referer" в сценарии www/delivery/tjs.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.openx.org

Решение: Установите последнюю версию 2.4.11, 2.6.5 или 2.8.0 с сайта производителя.

Ссылки: http://resources.enablesecurity.com/advisories/openx-2.6.4-multiple.txt

или введите имя

CAPTCHA