Несколько уязвимостей в Amaya

Дата публикации:
27.04.2009
Дата изменения:
27.04.2009
Всего просмотров:
1594
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Amaya 11.x
Уязвимые версии: Amaya 11.1 для Windows, возможно другие версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных при обработке "script" тегов, содержащих слишком длинный атрибут "defer". Удаленный пользователь может с помощью специально сформированного Web сайта вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных в функции "ParseCharsetAndContentType()" в файле amaya/XHTMLbuilder.c. Удаленный пользователь может с помощью специально сформированного HTML файла, содержащего определение слишком длинной кодировки, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.w3.org/Amaya/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Amaya 11.1 W3C Editor/Browser Stack Overflow PoC
Amaya 11.1 W3C Editor/Browser (defer) Stack Overflow Exploit
Amaya 11.1 XHTML Parser Remote Buffer Overflow PoC

или введите имя

CAPTCHA