Раскрытие важных данных в Apache mod_proxy_aj

Дата публикации:
22.04.2009
Дата изменения:
03.09.2009
Всего просмотров:
3222
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache 2.2.x
Уязвимые версии: Apache 2.2.11

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным.

Уязвимость существует из-за ошибки в mod_proxy_ajp при обработке некорректно сформированных HTTP POST запросов. Удаленный пользователь может с помощью специально сформированных HTTP запросов просмотреть данные, возвращаемые в качестве ответов другим пользователям.

URL производителя: www.apache.org

Решение: Установите последнюю версию 2.2.12 с сайта производителя.

Журнал изменений:

30.07.2009
Изменена секция «Решение».
03.09.2009
Незначительные изменения.

Ссылки: http://svn.apache.org/viewvc/httpd/httpd/trunk/CHANGES?r1=766938&r2=767089
https://issues.apache.org/bugzilla/show_bug.cgi?id=46949
http://www.apache.org/dist/httpd/CHANGES_2.2.12

или введите имя

CAPTCHA