Множественные уязвимости в Xpdf

Дата публикации:
17.04.2009
Дата изменения:
17.04.2009
Всего просмотров:
2458
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-0146
CVE-2009-0147
CVE-2009-0166
CVE-2009-0195
CVE-2009-0799
CVE-2009-0800
CVE-2009-1179
CVE-2009-1180
CVE-2009-1181
CVE-2009-1182
CVE-2009-1183
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Xpdf 3.x
Уязвимые версии: Xpdf версии до 3.02pl3

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести DoS атаку и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных при декодировании сегментов словаря JBIG2 символов. Удаленный пользователь может с помощью специально сформированного PDF файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

2. Целочисленные переполнения обнаружены в JBIG2 декодере. Удаленный пользователь может с помощью специально сформированного PDF файла выполнить произвольный код на целевой системе.

3. Уязвимость существует из-за множественных ошибок в JBIG2 декодере. Удаленный пользователь может вызвать переполнение буфера и выполнить произвольный код на целевой системе.

4. Уязвимость существует из-за множественных ошибок в JBIG2 декодере. Удаленный пользователь может вызвать освобождение памяти и выполнить произвольный код на целевой системе.

5. Множественные уязвимости существуют из-за ошибок проверки входных данных в JBIG2 декодере. Удаленный пользователь может выполнить произвольный код на целевой системе.

URL производителя: www.foolabs.com/xpdf/

Решение: Установите последнюю версию 3.02pl3 с сайта производителя.

Ссылки: Secunia Research: Xpdf JBIG2 Symbol Dictionary Buffer Overflow Vulnerability
http://rhn.redhat.com/errata/RHSA-2009-0430.html

или введите имя

CAPTCHA