Инклюдинг локальных файлов в blog+

Дата публикации:
16.04.2009
Дата изменения:
16.04.2009
Всего просмотров:
2288
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
blog+ 1.x
Уязвимые версии: blog+ 1.0, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным на системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "row_mysql_blocks_center_down[file]" в сценарии includes/block_center_down.php, в параметре row_mysql_blocks_center_top[file]" в сценарии includes/block_center_top.php, в параметре "row_mysql_blocks_left[file]" в сценарии includes/block_left.php, в параметре "row_mysql_blocks_right[file]" в сценарии includes/block_right.php, в параметре "row_mysql_bloginfo[theme]" в сценарии includes/window_down.php и в параметре "row_mysql_bloginfo[theme]" в сценарии includes/window_top.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

URL производителя: www.blogplus.li/en/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/8290