Переполнение буфера в IBM Access Support ActiveX компоненте

Дата публикации:
14.04.2009
Дата изменения:
14.04.2009
Всего просмотров:
2071
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IBM Access Support ActiveX Control (eGatherer) 2.x
IBM Access Support ActiveX Control (eGatherer) 3.x
Уязвимые версии: IBM Access Support ActiveX 3.20.284.0 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в методе "GetXMLValue()" в библиотеке IbmEgath.dll. Удаленный пользователь может с помощью специально сформированного Web сайта передать слишком длинный аргумент уязвимому методу, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.ibm.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.kb.cert.org/vuls/id/340420

или введите имя

CAPTCHA