Переполнение буфера в ldns

Дата публикации:
14.04.2009
Дата изменения:
14.04.2009
Всего просмотров:
1427
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ldns 1.x
Уязвимые версии: ldns версии до 1.5.0

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "ldns_rr_new_from_str_internal()" в файле rr.c при обработке DNS Resource записей. Удаленный пользователь может с помощью специально сформированной DNS Resource записи вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.nlnetlabs.nl/projects/ldns/

Решение: Установите последнюю версию 1.5.1 с сайта производителя.

Ссылки: http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=232
http://www.nlnetlabs.nl/svn/ldns/tags/release-1.5.1/Changelog

или введите имя

CAPTCHA