Множественные уязвимости в PGP Desktop

Дата публикации:
13.04.2009
Дата изменения:
16.04.2009
Всего просмотров:
2958
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PGP Corporate Desktop 9.x
Уязвимые версии: PGP Desktop 9.9.0 build 397, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют локальному пользователю вызвать отказ в обслуживании и повысить свои привилегии на системе.

1. Уязвимость существует из-за ошибки проверки входных данных в драйвере pgpdisk.sys. Локальный пользователь может с помощью специально сформированного IOCTL запроса аварийно завершить работу системы.

2. Уязвимость существует из-за ошибки проверки входных данных в драйвере pgpwded.sys. Локальный пользователь может с помощью специально сформированного IOCTL запроса аварийно завершить работу системы или выполнить произвольный код с повышенными привилегиями (SYSTEM).

Благодарности: Уязвимость обнаружил Никита Тараканов, Positive Technologies Research Team.

URL производителя: www.pgp.com

Решение: Установите последнюю версию 9.10 с сайта производителя.

Ссылки: http://www.securitylab.ru/lab/PT-2009-01
https://pgp.custhelp.com/cgi-bin/pgp.cfg/php/enduser/std_adp.php?p_faqid=1014&p_topview=1

или введите имя

CAPTCHA