Множественные уязвимости в phpMyAdmin

Дата публикации:
13.04.2009
Дата изменения:
13.04.2009
Всего просмотров:
2569
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1150
CVE-2009-1151
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpMyAdmin 2.x
phpMyAdmin 3.x
Уязвимые версии: phpMyAdmin версии до 2.11.9.5 и 3.1.3.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки конфигурационных параметров во время установки. Злоумышленник может внедрить произвольный PHP код и выполнить его после установки приложения.

URL производителя: www.phpmyadmin.net

Решение: Установите последнюю версию 2.11.9.5 или 3.1.3.1 с сайта производителя.

Ссылки: http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin?view=rev&revision=12301
http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin?view=rev&revision=12302
http://www.phpmyadmin.net/home_page/security/PMASA-2009-2.php
http://www.phpmyadmin.net/home_page/security/PMASA-2009-3.php

или введите имя

CAPTCHA