Межсайтовый скриптинг в ExpressionEngine

Дата публикации:
13.04.2009
Дата изменения:
13.04.2009
Всего просмотров:
2172
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ExpressionEngine 1.x
Уязвимые версии: ExpressionEngine 1.6.6 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "avatar" в сценарии system/index.php, когда параметр "M" установлен в значение "select_avatar" и параметр "C" равен "myaccount". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.pmachine.com/ee/

Решение: Установите последнюю версию 1.6.7 с сайта производителя.

Ссылки: http://www.ngenuity.org/wordpress/2009/01/28/ngenuity-2009-003-expressionengine-persistent-cross-site-scripting/
http://expressionengine.com/docs/changelog.html#v167

или введите имя

CAPTCHA