Множественные уязвимости в Wireshark

Дата публикации:
09.04.2009
Дата изменения:
27.04.2009
Всего просмотров:
2389
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2009-1210
CVE-2009-1267
CVE-2009-1268
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Wireshark 1.x
Уязвимые версии: Wireshark версии до 1.0.7

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки форматной строки в PROFINET/DCP (PN-DCP) диссекторе при обработке названий станций, содержащих символы форматной строки. Удаленный пользователь может с помощью специально сформированного пакета вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки в LDAP диссекторе. Удаленный пользователь может с помощью специально сформированного LDAP пакета аварийно завершить работу приложения. Уязвимость распространяется только на Windows платформы.

3. Уязвимость существует из-за ошибки в Check Point High-Availability Protocol (CPHAP) диссекторе. Удаленный пользователь может аварийно завершить работу приложения.

4. Уязвимость существует из-за ошибки при обработке Tektronix .rf5 файлов. Удаленный пользователь может с помощью специально сформированного .rf5 файла аварийно завершить работу приложения.

URL производителя: www.wireshark.org

Решение: Установите последнюю версию 1.0.7 с сайта производителя.

Ссылки: http://www.wireshark.org/security/wnpa-sec-2009-02.html

или введите имя

CAPTCHA